Joomla! 3.5 is available in one click

The Joomla! development team has just released version 3.5 of the CMS to millions of users across the world. OVH customers can now install this new version in one click and enjoy a long list of improvements. Overview.

Joomla! 3.5 officially supports PHP 7. This combination allows for better code management and a significant improvement in website latency as a consequence. Initial tests have demonstrated website loading speeds which are 50% faster than the previous version!

Expert advice

Our Personal, Professional and Performance hosting solutions have been compatible with PHP 7 since October 2015. From now on the combination of PHP 7 and Joomla! 3.5 will allow for: enhanced security, faster loading speeds, substantial plugin compatibility and more besides. If this is your first Joomla! website installation, you don't have to do anything: the latest version is preinstalled by default when you order a hosting solution.

What's new?

Broadly speaking, Joomla! 3.5 includes the following headline improvements:

You can now drag and drop images right into the Joomla! TinyMCE editor
Administrators will get email notification of new updates
The Category Manager displays the number of published, unpublished and trashed articles in every category.

All of the new features are available on the project's development page

Should I update my current Joomla! website?
Although it is not compulsory, we strongly recommend version 3.5 of Joomla! for two reasons: the security and responsiveness of your websites.

Security is the no.1 factor because each time there is an update, developers and the community work to make the CMS even more robust and stable so that it can deal with possible intrusion attempts. As indicated on the technical page for the 3.5 project, there have been nearly 2000 commits since 2.4.8's release.

Responsiveness is another important consideration. As we have witnessed in-house, the improvements in loading speed for Joomla! 3.5 websites in PHP 7 are significant. When you think about it, the maths is simple: you can upgrade in one click and an internet user will spend no longer than 3 seconds waiting for a page to load.

Precautions
When updating your current Joomla! installation, make sure that your additional plugins are compatible with Joomla! 3.5 and PHP 7 before continuing with your update.
Reminder: you can update Joomla! 3.4 to Joomla! 3.5 in one click from the update module.

Go further